Задать вопрос
19 марта, 01:27

Напишите программу, которая определяет, верно ли, что введённое число состоит из одинаковых цифр. (ABC pascal)

+4
Ответы (2)
  1. 19 марта, 01:47
    0
    Var number:integer;

    digit:integer;

    res:boolean;

    begin

    readln (number) ;

    digit:=number mod 10;

    number:=number div 10;

    res:=true;

    while number>0 do begin

    if digitnumber mod 10 then begin

    res:=false;

    break;

    end;

    number:=number div 10;

    end;

    if res then writeln ('Верно') else writeln ('Неверно') ;

    end.
  2. 19 марта, 02:49
    0
    Var x, x1, k, s:integer; d:real;

    begin

    readln (x) ;

    k:=0; s:=0;

    while x>0 do

    begin

    x1:=x mod 10;

    k:=k+1;

    s:=s+x1;

    x:=x div 10;

    end;

    d:=s/k;

    if d=x1 then writeln ('Верно')

    else writeln ('Неверно') ;

    end.

    x-вводимое число, x1-каждая цифра, k-кол-во цифр, s-сумма цифр, d-среднее арифметическое цифр
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая определяет, верно ли, что введённое число состоит из одинаковых цифр. (ABC pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите программу, которая определяет, верно ли, что введенное число состоит из одинаковых цифр (например, 222) 2) Напишите программу, которая определяет, верно ли, что введеное число содержит две одинаковые цифры, стоящие рядом (например, 221)
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
1. Составьте программу в Pascal ABC. Известно, что X кг конфет стоит A рублей. Определить, сколько стоит 1 кг и Y кг этих же конфет. 2. Составьте программу в Pascal ABC. Дано двузначное число. Найти сумму и произведение его цифр. 3.
Ответы (1)
Программа паскаль Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)