Задать вопрос
18 марта, 22:55

C клавиатуры вводятся 30 чисел. Найти произведение положительных чисел.

+1
Ответы (1)
  1. 19 марта, 02:47
    0
    Var a, b, c:integer;

    begin

    writeln ('введите 30 чисел') ;

    readln (a) ;

    b:=1;

    c:=1;

    while b30 do begin

    if a > 0 then c:=a*c;

    readln (a) ;

    b:=b+1;

    end; writeln ('ответ ', c) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «C клавиатуры вводятся 30 чисел. Найти произведение положительных чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) C клавиатуры вводятся 10 чисел. Найти сумму тех из них, которые больше 10. 2) Найти произведение двузначных нечетных чисел. 3) С клавиатуры вводятся N чисел.
Ответы (1)
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
1. Напишите программу вычисления корней квадратного уравнения, если с клавиатуры, если коэффициенты вводятся с клавиатуры (a, b, c) 2. Координаты 2-х точек плоскости вводятся с клавиатуры.
Ответы (1)
Задания по Pascal №1 найти все двузначные числа, такие, что сумма цифр равна A, а само число делится на B. A и B вводятся с клавиатуры. №2 найти сумму всех чисел из промежутка от A до B, кратных 5. A и B вводятся с клавиатуры.
Ответы (1)
1) с клавиатуры вводятся количество целых чисел и сами числа. найти среднее арифметическое квадратов введенных чисел 2) с клавиатуры вводятся натуральные числа a и n. Написать программу вычисления a в степени n.
Ответы (1)