Задать вопрос
17 февраля, 08:19

Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ' true ', если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей

+5
Ответы (1)
  1. 17 февраля, 11:03
    0
    Это реализовано с помощью цикла for:

    Program p1;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    For i:=0 to 1 do

    Begin

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    End;

    if k=2 then

    Writeln ('Эта последовательность является возрастающей') else

    Writeln ('Эта последовательность не является возрастающей') ;

    End.

    Это реализовано с помощью цикла while:

    Program p2;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    While i2 do

    Begin

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    i:=i+1;

    End;

    if k=2 then Writeln ('Эта последовательность является возрастающей') else Writeln ('Эта последовательность не является возрастающей') ;

    End.

    Это реализовано с помощью цикла repeat:

    Program p3;

    Var a1, a2, k, i:integer;

    Begin

    Write ('Введите число: ') ;

    Readln (a1) ;

    repeat

    Begin

    i:=i+1;

    Write ('Введите число: ') ;

    Readln (a2) ;

    if a2>a1 then

    k:=k+1;

    a1:=a2;

    End;

    until i=2;

    if k=2 then

    Writeln ('Эта последовательность является возрастающей') else

    Writeln ('Эта последовательность не является возрастающей') ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Реализовать с помощью 3-х циклов: while, repeat, for) Составить программу, которая выдавала бы сообщение ' true ', если последовательность ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1.8. Составить программу, которая выдавала бы сообщение ' true ', если последовательность из N целых чисел, вводимых с клавиатуры, является возрастающей
Ответы (1)
Выберите логическое выражение, принимающее значение True a) (True and True) and (False or False) b) Not (True and Not False) or False c) (True or False) or Not (True and True) d) Not (True or False) and True
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1) Какие операторы используются для организации циклов? a) while условие until; b) repeat until условие; c) while условие do; d) repeat do условие.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)