Задать вопрос
22 ноября, 16:11

Помогите решить задачи ...

1. У Тани было N (N>0) палочек. Она разломала одну из них на 4 куска. Сколько теперь у неё палочек?

2. В N году ежегодная олимпиада по информатике среди учеников 1-8 классов проводится в Беларуси уже M раз. В каком году была проведена первая олимпиада?

3. Пятачок посадил N1 семечек. Из всех семечек, кроме N2, выросли яблони. На всех яблонях, кроме N3, растут яблоки. Яблоки со всех плодоносящих яблонь, кроме N4,-невкусные. Значит, число яблонь с невкусными яблоками равно K.

4. Пример ввода - 1,7 Пример ввода - 6,3

Пример вывода - Round (1,7) = 2 Пример вывода - Round (6,3) = 6

+4
Ответы (1)
  1. 22 ноября, 19:04
    0
    Program schet;

    var a:integer;

    label h;

    begin

    h:

    begin

    writeln ('Введите количество палочек: ') ;

    readln (a) ;

    if (a<=0) then goto h

    else

    a:=a+3;

    writeln ('У Тани стало ', a, ' палочек') ;

    end;

    readln;

    end.

    Program schet;

    var a, b:integer;

    begin

    a:=2015;

    writeln ('Сколько лет проводится олимпиада?') ;

    readln (b) ;

    a:=a-b;

    writeln ('Первая олимпиада была проведена в ', a,' году.') ;

    readln;

    end.

    Program schet;

    var a, b, c, i:integer;

    begin

    writeln ('Сколько семечек посадил Пятачок?') ;

    readln (a) ;

    writeln ('Сколько семечек не выросло?') ;

    readln (b) ;

    a:=a-b;

    writeln ('Сколько не плодоносных яблонь?') ;

    readln (c) ;

    a:=a-c;

    writeln ('На скольки яблонях вкусные яблоки?') ;

    readln (i) ;

    a:=a-i;

    if (a<0) then writeln ('Выросло 0 яблонь с невкусными яблоками.')

    else writeln ('Выросло ', a,' яблонь с невкусными яблоками.') ;

    readln;

    end.

    Program schet;

    var a:real;

    begin

    writeln ('Введите число, которое нужно округлить:') ;

    readln (a) ;

    a:=round (a) ;

    writeln ('Ответ после округления: ', a) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачи ... 1. У Тани было N (N>0) палочек. Она разломала одну из них на 4 куска. Сколько теперь у неё палочек? 2. В N году ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Верное высказывание: а) Принтер - устройство ввода/вывода б) CD - ROM - устройство вывода в) Компакт-диск - устройство для хранения информации г) Клавиатура устройство ввода/вывода д) Монитор - устройство ввода
Ответы (1)
1. Устройство вывода звуковой информации (8 букв) 2. Устройство ввода информации и работы с графическим интерфейсом (4 букв) 3. Назовите устройство ввода текстовой информации (10 букв) 4. устройство ввода звуковой информации (8 букв) 5.
Ответы (1)
Составьте программу ввода с клавиатуры элементов массива a[1 ... 8] и вывода элементов массива в обратном порядке (пример ввода: 1 2 3 4 5 6 7 8 пример вывода 8 7 5 4 3 2 1
Ответы (1)
Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ддоожжддьь
Ответы (1)
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)