Задать вопрос
29 апреля, 11:22

Заполнить массив из 10 элементов в интервале [-50 ... 50] и отсортировать его по убыванию.

+2
Ответы (1)
  1. 29 апреля, 13:46
    0
    Program t1;

    var

    i, j: integer;

    mas: array [1 ... 10] of integer;

    begin

    randomize;

    writeln ('сгенерированный масив: ') ;

    for i : = 1 to 10 do

    begin

    mas[i] : = random (100) - 50;

    write (mas[i]) ;

    end;

    begin

    for j:=1 to 9 do

    for i:=1 to 9-j do

    if M[i] < M[i+1] then

    swap (mas[i], mas[i+1])

    end;

    writeln ('отсортированный по убыванию массив: ') ;

    for i : = 1 to 10 do write (mas[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить массив из 10 элементов в интервале [-50 ... 50] и отсортировать его по убыванию. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить задачи с помощью Паскаля: 1. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать его по последней цифре. 2. Заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (2)
Помогите решить задачи по икт. 1 заполнителя массив из 10 элементов случайными числами в интервале [-10 ... 10] и выполнить циклический сдвиг вправо. 2 заполнить массив из 10 элементов случайными числами в интервале [0 ...
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Язык программирования: Паскаль. Написать программу. Заполнить массив из 10 элементов случайными числами в интервале [0 ... 100] и отсортировать первую половину по возрастанию, а вторую - по убыванию.
Ответы (1)
1) Задан числовой массив из 10 элементов [5; 150]Отсортировать массив по убыванию. 2) В комп. вводятся результ. экзаменов для 20 абитуриентов. Вывести на экран фамилии и результ. [10; 30]. Подсчитать их сред. ариф. 3) Дан массив из 10 элементов.
Ответы (1)