Задать вопрос
12 декабря, 13:51

1. В одномерном массиве произвольных чисел А (10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов

+5
Ответы (1)
  1. 12 декабря, 14:02
    0
    Const

    n = 10;

    var

    a: array[1 ... n] of integer;

    i: integer;

    begin

    Randomize;

    Writeln ('Исходный массив') ;

    for i : = 1 to n do

    begin

    a[i] : = Random (51) - 25;

    Write (a[i]:4) ;

    end;

    Writeln;

    Writeln ('Результирующий массив') ;

    for i : = 1 to n do

    begin

    if a[i] > 0 then a[i] : = a[i] div 2 else a[i] : = i;

    Write (a[i]:4) ;

    end;

    Writeln;

    end.

    Тестовое решение:

    Исходный массив

    5 - 19 - 24 - 21 - 4 14 - 18 - 21 2 - 14

    Результирующий массив

    2 2 3 4 5 7 7 8 1 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В одномерном массиве произвольных чисел А (10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна содержаться сумма индексов.
Ответы (1)
1. в одномерном массиве найти значение и номер минимального элемента. 2. в одномерном массиве заменить все элементы кратные 3 на 0.
Ответы (1)
1) В числовом одномерном массиве все элементы массива, кратные 3, возвести в куб. В новом массиве найти сумму всех членов массива.
Ответы (1)
Напишите программу, которая сортирует одномерный массив. Дана матрица размерами 4 на 4. Заполните ее следующим образом: Если сумма индексов четная - в ячейке должно содержаться произведение индексов, если сумма индексов нечетная - в ячейке должна
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)