Задать вопрос
16 октября, 09:16

Даны длины двух катетов a и b прямоугольного треугольника. Определить периметр этого треугольника P.

+1
Ответы (2)
  1. 16 октября, 11:35
    0
    Program Trapez;

    uses Crt;

    var a, b, alfa: real;

    h, S: real;

    begin

    ClrScr; {}

    repeat

    Write (' alfa (w grad) = ') ; ReadLn (alfa) ;

    Write (' a = ') ; ReadLn (a) ;

    Write (' b = ') ; ReadLn (b) ;

    until (a>b) and (alfa90) ;

    alfa:=alfa*pi/180;

    h: = (a-b) / 2*sin (alfa) / cos (alfa) ;

    S: = (a+b) * h/2;

    WriteLn (' S = ', S:6:2) ;

    ReadLn;

    end.
  2. 16 октября, 11:35
    0
    P=a+b+c a, b - катеты c - гипотенуза

    с²=а²+b² - теорема Пифагора

    P = a + b + √ (a² + b ²)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны длины двух катетов a и b прямоугольного треугольника. Определить периметр этого треугольника P. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)
Даны длины двух катетов (a, b) прямоугольного треугольника. Определить периметр этого треугольника (P), если: а) a=3, b=4; б) a=0, b=3; в) a=6, b=8; г) a=9, b=12.
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)
Даны длины катетов и площадь, вычислить периметр и площадь прямоугольного треугольника.
Ответы (1)
Написать программу в паскале Найти периметр и площадь прямоугольного треугольника, если даны длины его катетов a и b.
Ответы (1)