Задать вопрос
25 июля, 07:56

Помогите написать программу в Паскале ... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

+2
Ответы (1)
  1. 25 июля, 09:07
    0
    Var

    m, n, n1, n2, n3, n4:integer;

    begin

    Write ('Введите трехзначное натуральное число: ') ;

    Readln (n) ;

    n1: = n mod 10;

    n2: = (n mod 100) div 10;

    n3: = n div 100;

    m:=n1+n2+n3;

    Write ('сумма цифр: ', m) ;

    Write ('среднее арифметическое: ', m/3) ;

    m = 100*n1 + 10*n2 + n3;

    Writeln (' в обратном порядке: ', m)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскале ... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Паскаль. 1) Дано трехзначное число, нужно найти число, полученное при прочтении его цифр справа налево. 2) Дано трехзначное число. В нем зачеркнули последнюю справа цифру и приписали ее в начале. Найти полученное число. 3) Дано трехзначное число.
Ответы (1)