Задать вопрос
3 мая, 15:51

Введите с клавиатуры 5 значное число и посчитайте произведение нечетных цифр числа

+1
Ответы (2)
  1. 3 мая, 18:28
    0
    Var ab, sum: integer;

    a: array[1 ... 5] of integer;

    begin

    readln (ab) ;

    a[1]: = ab div 10000;

    a[2]: = ab mod 10000 div 1000;

    a[3]: = ab mod 1000 div 100;

    a[4]: = ab mod 100 div 10;

    a[5]: = ab mod 10;

    for i: integer: = 1 to 5 do

    if a[i] mod 2 = 1

    then sum+=a[i];

    writeln (sum) ;

    end.
  2. 3 мая, 18:33
    0
    Program tak;

    var a, b, c, d:integer;

    begin writeln ('введите пятизначное число ') ;

    readln (a) ;

    d:=1;

    while (a0) do

    begin

    b:=a mod 10;

    if (b mod 2 0) then

    d:=d*b;

    a:=a div 10;

    end;

    writeln (d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Введите с клавиатуры 5 значное число и посчитайте произведение нечетных цифр числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)