Задать вопрос
7 апреля, 09:08

Задача в Pascal abc.

Подсчитать количество двузначных чисел, которые кратны 3

+5
Ответы (2)
  1. 7 апреля, 10:08
    0
    Const

    start=12; / / наименьшее подходящее число

    max=100; / / первое число, идущее после всех двузначных

    step=3; / / разность между подходящими числами

    var

    x, i:integer;

    begin

    x:=start;

    i:=0;

    while x
    i:=i+1;

    x:=x+step;

    end;

    writeln ('Количество искомых чисел: ', i) ;

    end.
  2. 7 апреля, 12:19
    0
    12, 15, 18, 21, 24, 27, 30, 33, 36, 39, 42, 45, 48, 51, 54, 57, 60, 63, 66, 69, 72, 75, 78, 81, 84, 87, 90, 93, 96, 99. Итого 30.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача в Pascal abc. Подсчитать количество двузначных чисел, которые кратны 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача в Pascal abc. Cоздать программу и подсчитать количество двузначных чисел, которые кратны 3
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1. В одномерном массиве подсчитать сумму тех элементов массива, которые кратны 5, но не делятся на 3. 2. В одномерном массиве подсчитать произведение тех элементов массива, которые стоя на индексах, кратных 3, а сами элементы четные.
Ответы (2)
Задание 1. составьте программу вычисления количества двузначных чисел, которые кратны 2 и 3. задание 2. составьте программу, выводящую на экран все двузначные числа, у которых первая цифра в два раза больше второй. задание 3.
Ответы (1)