Задать вопрос
30 апреля, 19:18

Помогите решить задачу по информатике по паскалю. Все четные числа из диапазона от А до В, кратные трём (А<=В)

+3
Ответы (1)
  1. 30 апреля, 20:45
    0
    Var

    a, b, n:integer;

    begin

    Write ('Введите нижнюю и верхнюю границы: ') ; Readln (a, b) ;

    n:=a mod 6;

    if n=0 then n:=a else n:=a+6-n;

    Writeln ('Четные числа, кратные трем из указанного диапазона') ;

    while n<=b do begin Write (n,' ') ; n:=n+6 end;

    Writeln

    end.

    Тестовое решение:

    Введите нижнюю и верхнюю границы: 13 42

    Четные числа, кратные трем из указанного диапазона

    18 24 30 36 42
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу по информатике по паскалю. Все четные числа из диапазона от А до В, кратные трём (А ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
С помощью оператора Паскаля FOR Вывести на экран: 1) все четные числа из диапазона от A до B, кратные трем (A 2) все двузначные числа, в которых старшая цифра отличается от младшей не больше чем на 1;
Ответы (1)
Решить в Паскале с помощью операторов while и repeat 1) Вывести на экран все четные числа из диапазона от A до В, кратные трём (А
Ответы (1)
С# Решите задачу тремя способами - используя операторы цикла while, do while и for. Вывести на экран: все целые числа из диапазона от А до В, кратные трем (А
Ответы (1)
Целое число было выбрано наугад из заданного диапазона чисел. Сообщение о выборе числа из какого диапазона несет наименьшее количество информации: a) от 12 до 76 b) от 100 до 133 c) от - 17 до 25 d) от - 32 до 0 e) от 12 до 34
Ответы (1)