Задать вопрос
25 апреля, 16:20

С помощью оператора Паскаля FOR

Вывести на экран:

1) все четные числа из диапазона от A до B, кратные трем (A 2) все двузначные числа, в которых старшая цифра отличается от младшей не больше чем на 1;

3) все трехзначные числа, в которых хотя бы две цифры повторяются.

+3
Ответы (1)
  1. 25 апреля, 16:31
    0
    1)

    Var i, a, b:longint;

    Begin

    read (a, b) ;

    for i:=a to b do

    if (i mod 3=0) then write (i,' ') ;

    writeln;

    End.

    2)

    Var i:longint;

    Begin

    for i:=10 to 99 do

    if (abs (i mod 10 - i div 10) <=1) then write (i,' ') ;

    writeln;

    End.

    3)

    Var i, s, f, t:longint;

    Begin

    for i:=100 to 999 do

    begin

    f:=i div 100;

    s:=i div 10 mod 10;

    t:=i mod 10;

    if (f=s) or (f=t) or (s=t) then write (i,' ') ;

    end;

    writeln;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С помощью оператора Паскаля FOR Вывести на экран: 1) все четные числа из диапазона от A до B, кратные трем (A 2) все двузначные числа, в ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить в Паскале с помощью операторов while и repeat 1) Вывести на экран все четные числа из диапазона от A до В, кратные трём (А
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Помогите решить в turbo pascal. Вывести на экран все двухзначные числа в которых старшая цифра отличается от младшей не больше чем на 1 (с помощью оператора for).
Ответы (2)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)