Задать вопрос
21 сентября, 02:16

Как составить программу для решения алгоритма: Дан массив А (n, n). Нужно поменять местами элементы к - и j - строки этого массива

+5
Ответы (1)
  1. 21 сентября, 03:36
    0
    Const

    n=10;

    var

    i, j, k, m, buf:integer;

    a:array[1 ... n, 1 ... n]of integer;

    begin

    for i:=1 to n do

    begin

    writeln;

    for m:=1 to n do

    begin

    a[i, m]:=random (20) ;

    write (a[i, m]:4) ;

    end;

    end;

    writeln;

    writeln ('k, j?') ;

    readln (k, j) ;

    for m:=1 to n do

    begin

    buf:=a[k, m];

    a[k, m]:=a[j, m];

    a[j, m]:=buf;

    end;

    for i:=1 to n do

    begin

    writeln;

    for m:=1 to n do

    write (a[i, m]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как составить программу для решения алгоритма: Дан массив А (n, n). Нужно поменять местами элементы к - и j - строки этого массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)