Задать вопрос
9 мая, 18:35

Дана строка. Проверьте, если ли в строке еще один символ равный последнему. Вывести 'yes' или 'no' Сделать программу в паскале

+2
Ответы (2)
  1. 9 мая, 18:47
    0
    Var

    s:string;

    i, n:integer;

    begin

    Write ('Введите строку: ') ; Readln (s) ;

    n:=Length (s) ;

    i:=Pos (s[n], s) ;

    if (i>0) and (in) then Writeln ('Yes')

    else Writeln ('No')

    end.
  2. 9 мая, 19:40
    0
    Program z1;

    var s:string;

    var i, n, f:integer;

    var ch:char;

    begin

    writeln ('Введите строку') ;

    readln (s) ;

    f:=0;

    n:=length (s) ;

    ch:=s[n];

    for i:=1 to n do

    if (s[i]=ch) then

    f:=f+1;

    if (f0) then

    writeln ('yes')

    else writeln ('no') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка. Проверьте, если ли в строке еще один символ равный последнему. Вывести 'yes' или 'no' Сделать программу в паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Дана матрица размера M х N. Вывести ее элементы в следующем порядке: первая строка слева направо, вторая строка справа налево, третья строка слева направо, четвертая строка справа налево и т. д. в c++, code blocks
Ответы (1)
1) Дана строка. Показать третий, шестой, девятый и так далее символы. 2) Дана строка. Заменить каждый четный символ или на 'a', если символ не равен 'a' или 'b', или на 'c' в противном случае
Ответы (1)
Дана строка символов s и, далее, отдельно в новой строке дан одиночный символ с. Напишите программу, которая подсчитает, сколько раз символ с встретился в данной строке s. Составить блок-схему, не используя цикл с параметром.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)