Задать вопрос
16 ноября, 08:52

Дана строка символов s и, далее, отдельно в новой строке дан одиночный символ с. Напишите программу, которая подсчитает, сколько раз символ с встретился в данной строке s. Составить блок-схему, не используя цикл с параметром.

+2
Ответы (1)
  1. 16 ноября, 10:49
    0
    Var S:string;

    C:char;

    i, k:integer;

    Begin

    WriteLn ('Введите строку') ;

    ReadLn (S) ;

    WriteLn ('Введите символ') ;

    ReadLn (C) ;

    i:=1;

    k:=0;

    While i<=Length (S) do

    Begin

    if S[i] = C then k:=k+1;

    i:=i+1

    End;

    WriteLn (k) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана строка символов s и, далее, отдельно в новой строке дан одиночный символ с. Напишите программу, которая подсчитает, сколько раз символ ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
1) Дана строка. Показать третий, шестой, девятый и так далее символы. 2) Дана строка. Заменить каждый четный символ или на 'a', если символ не равен 'a' или 'b', или на 'c' в противном случае
Ответы (1)
Дана строка, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в ровно один раз. Формат входных данных Во входном файле дана строка.
Ответы (1)
Дана строка S, состоящая из слов, разделённых пробелами. Выведите все слова, которые встречаются в S ровно один раз. Формат входных данных Во входном файле дана строка S.
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)