Задать вопрос
18 октября, 17:42

Задать массив A (N) элементы которого являются членами ряда A (I) = I^3 не большими наперед заданного числа М>=1000 найти среднее значение элементов массива

+1
Ответы (1)
  1. 18 октября, 21:01
    0
    Const n = 9; / / Задаем кол-во элементов в массиве

    var

    i, sred:integer;

    a:array[1 ... n] of integer;

    begin

    for i:=1 to n do begin

    if i*i*i = 1000 then break;

    a[i]: = i*i*i;

    sred:=sred+a[i];

    end;

    writeln ('Среднее значение элементов = ', sred/n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задать массив A (N) элементы которого являются членами ряда A (I) = I^3 не большими наперед заданного числа М>=1000 найти среднее значение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан одномерный массив А[N], - целых чисел. Заменить все большие 7 члены массива числом 7. Найти количество таких членов. 2) Задан массив из 10 элементов, найти произведение элементов массива. Задача №3.
Ответы (1)