Задать вопрос
15 декабря, 03:34

Дано натуральное число N. Вычислить: s=1/1+1/2+1/3+⋯+1/N

составить программу в Паскале

+5
Ответы (1)
  1. 15 декабря, 06:29
    0
    Var

    i, n:integer;

    s:real;

    begin

    readln (n) ;

    for i:=1 to n do

    s:=s+1/i;

    writeln (s:4:2) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число N. Вычислить: s=1/1+1/2+1/3+⋯+1/N составить программу в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу в паскале 1. Вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2, дано натуральное число n. Вычислить (1+1/12)  (1+1/22)  ... (1+1/n2). 3. Дано целое число А.
Ответы (1)
1. Дано натуральное число. Найти первую цифру данного числа. 2. Дано натуральное число. Определить количество троек в нем. 3. Дано натуральное число. Определить количество четных цифр в нем. Все это при помощи цикла:while
Ответы (1)
Это цикл for: 1) даны натуральные числа X и Y. вычислить X*Y, пользуясь только оперцией сложения. 2) даны натуральные числа X и Y. вычислить X^Y 3) дано натуральное число N. найти сумму S=1+1/2+1/3 + ... + 1/N. 4) дано натуральное число N и число Х.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)