Задать вопрос
20 ноября, 06:55

Имеется информация об адресах учеников одного класса в виде: фамилия, имя, город, улица, № дома. Написать программу, позволяющую вывести список учеников, проживающих в городе

+3
Ответы (1)
  1. 20 ноября, 07:27
    0
    Type

    Uch=record

    fam:string[20];

    nam:string[20];

    city:string[20];

    street:string[20];

    numb:string[8]

    end;

    var

    f:file of Uch;

    bUch:Uch; { буфер }

    c:string;

    begin

    Assign (f,'Uch. txt') ;

    Reset (f) ;

    Write ('Введите название города: ') ; Readln (c) ;

    while not Eof (f) do begin

    Read (f, bUch) ;

    if c=Trim (bUch. city) then

    With bUch do Writeln (fam,' ', nam,' ', street,' ', numb)

    end;

    Close (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеется информация об адресах учеников одного класса в виде: фамилия, имя, город, улица, № дома. Написать программу, позволяющую вывести ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какая информация называется достоверной? Выберите один ответ: Информация, которую можно представить графически Информация, которой удобно пользоваться Информация с минимумом фактов Информация, адекватно описывающая предметную область Информация,
Ответы (2)
2 задачи по программированию: 1) Три точки заданы своими координатами (x1, y1), (x2, y2), (x3, y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого
Ответы (1)
С клавиатуры вводят строку Фамилия Имя Отчество Нужно составить программу, которая выводит а) "Имя Фамилия Отчество" - именно этот порядок б) "Фамилия Имя"
Ответы (1)
Какая информация называется субъективной? Выберите один ответ: Информация, которая передаётся от одного субъекта другому Информация на дискете отдельного пользователя Информация, отражающая точку зрения отдельного пользователя Информация в бумажной
Ответы (2)
В поездке пятеро друзей - Антон, Борис, Вадим, Дима и Гриша - знакомились с попутчицей. Они предложили ей отгадать их фамилии, причем каждый из них высказал одно истинное и одно ложное утверждение: Дима: "Моя фамилия Мишин, а фамилия Бориса -
Ответы (1)