Задать вопрос
10 января, 03:47

Пусть дан текст. Верно ли что в нем имеются буквы входящие в слово, задаваемое пользователем? Нужно прогрраммку, если можно с пояснениями

+1
Ответы (1)
  1. 10 января, 04:11
    0
    {ввожу текст, затем слово. Переменная flag нужна для того, чтобы в нее записать 1, если из слова встретиться в тексте хотя бы раз буква. Если это случилось, то Flag становится равной 1. К буквам слова и текста обращаемся как к массиву a[i] b[j]}

    var

    a, b:string;

    i, n, k, j, flag:integer;

    begin

    flag:=0;

    writeln ('Введите текст') ;

    readln (a) ;

    Writeln ('Введите слово') ;

    Readln (b) ;

    k:=length (a) ;

    n:=length (b) ;

    for i:=1 to n do

    for j:=1 to k do

    if a[i]=b[j]then

    flag:=1;

    if flag=1 then

    writeln ('Y')

    else

    writeln ('N') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пусть дан текст. Верно ли что в нем имеются буквы входящие в слово, задаваемое пользователем? Нужно прогрраммку, если можно с пояснениями ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Тема Множества: Дан текст из строчных латинских букв, за которым следует точка. Напечатать: - все буквы, входящие в текст не менее двух раз; - все буквы, входящие в текст по одному разу. В Паскале АВС
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
1. Дан двумерный целочисленный массив. 2. размерность массива задается пользователем. 3. случайные числа генерируются из промежутка (-m, m) 4. m задается пользователем.
Ответы (1)
1. Составить программу, отгадывающую натуральное четное число, загаданное пользователем. Ниже представлен рекомендуемый вариант диалога во время работы программы (жирным шрифтом выделены данные, вводимые пользователем).
Ответы (1)
Паскаль 1. Дано натуральное число N и N целых чисел, задаваемых пользователем. Определить, сколько среди этих N чисел двузначных. Массивы не использовать. 2. Дано натуральное число N и N целых трехзначных чисел, задаваемых пользователем.
Ответы (1)