Задать вопрос
29 января, 19:26

1. Дан двумерный

целочисленный массив.

2. размерность

массива задается пользователем.

3. случайные

числа генерируются из промежутка (-m, m)

4. m задается

пользователем.

Найти количество нулевых элементов над главной

диагональю

и Максимальный четный элемент на побочной

диагонали

+1
Ответы (1)
  1. 29 января, 20:16
    0
    Var

    mas: array [,] of integer;

    i, j, m, n, s, max: integer;

    f:boolean;

    begin

    write ('Введите размерность массива: ') ;

    readln (n) ;

    write ('Введите число m: ') ;

    readln (m) ;

    setlength (mas, n+1, n+1) ;

    for i:=1 to n do

    begin;

    for j:=1 to n do

    begin

    mas[i, j]:=random (-m, m) ;

    write (mas[i, j]:6) ;

    if (j>i) and (mas[i, j]=0) then s:=s+1;

    end;

    writeln;

    end;

    j:=n;

    f:=false;

    for i:=1 to n do

    begin

    if (mas[i, j] mod 2=0) then

    begin

    if f=false then

    begin

    max:=mas[i, j];

    f:=true;

    end;

    if (mas[i, j]>max) then max:=mas[i, j];

    end;

    j:=j-1;

    end;

    writeln ('Число нулей над гл. диагональю: ', s) ;

    writeln ('Максимальный четный на доп. диагонали: ', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан двумерный целочисленный массив. 2. размерность массива задается пользователем. 3. случайные числа генерируются из промежутка (-m, m) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)