Задать вопрос
9 июля, 18:33

Помогите решить В заданной матрице заменить К-ю строку и L-й столбец нулями, кроме элемента, расположенного на их пересечении.

+2
Ответы (1)
  1. 9 июля, 19:23
    0
    var k, l, i, j, m:integer;

    a:array[1 ... 10,1 ... 10] of integer;

    begin

    randomize;

    for i:=1 to 10 do

    for j:=1 to 10 do

    a[i, j]:=random (10) - 5;

    for i:=1 to 10 do

    begin

    for j:=1 to 10 do write (a[i, j]:5) ;

    writeln;

    end;

    write ('K=') ;

    readln (k) ;

    write ('L=') ;

    readln (l) ;

    m:=a[k, l];

    for i:=1 to 10 do

    for j:=1 to 10 do

    if k=i then a[i, j]:=0 else if l=j then a[i, j]:=0;

    a[k, l]:=m;

    for i:=1 to 10 do

    begin

    for j:=1 to 10 do write (a[i, j]:5) ;

    writeln;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить В заданной матрице заменить К-ю строку и L-й столбец нулями, кроме элемента, расположенного на их пересечении. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Turbo Pascal Напишите программу, которая в заданной матрице заменяет все положительные элементы нулями, если количество отрицательных элементов окажется больше, чем количество положительных элементов.
Ответы (1)
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Сформируйте массив из 12 случайных чисел, которые принадлежат промежутку (-5; 5). Выведите 4 первых элемента массива в строку, а 3 последних элемента в столбец
Ответы (1)
Написать на C++:в матрице 4*5 замените на - 2 столбцы с положительными суммами элементов, а затем в качестве первого вставьте столбец из минимальных элементов соответственных строк
Ответы (1)