Задать вопрос
2 января, 07:07

Написать на C++:в матрице 4*5 замените на - 2 столбцы с положительными суммами элементов, а затем в качестве первого вставьте столбец из минимальных элементов соответственных строк

+4
Ответы (1)
  1. 2 января, 08:44
    0
    Если я все правильно понял, то так:

    #include

    #include

    /*

    Написать на C++:в матрице 4*5 замените на - 2 столбцы с положительными суммами элементов,

    а затем в качестве первого вставьте столбец из минимальных элементов соответственных строк

    */

    #define N 4 / / строки

    #define M 5 / / столбцы

    int main ()

    {

    int

    matrix[N][M],

    sum (0) ;

    for (int i = 0; i < N; i++) / / инициализируем матрицу.

    {

    for (int j = 0; j < M; j++)

    {

    std::cin >> matrix[i][j];

    }

    }

    for (int i = 0; i < N; i++) / / выводим начальную матрицу

    {

    for (int j = 0; j < M; j++)

    {

    std::cout << matrix[i][j] << " ";

    }

    std::cout << std::endl;

    }

    for (int j = 0; j < M; j++) / / выполняем 1 задание

    {

    for (int i = 0; i < N; i++)

    {

    sum+=matrix[i][j];

    }

    if (sum)

    {

    for (int i = 0; i < N; i++)

    {

    matrix[i][j] + = - 2;

    }

    }

    }

    int minimal (0) ;

    for (int i = 0; i < N; i++) / / выполняем второе задание

    {

    minimal = std::min (matrix[i][0], matrix[i][M-1]) ;

    matrix[i][0] = minimal;

    }

    for (int i = 0; i < N; i++)

    {

    for (int j = 0; j < M; j++)

    {

    std::cout << matrix[i][j] << " ";

    }

    std::cout << std::endl;

    }

    }

    p. s я не заморачивался насчет читабельности и оптимизации кода, ибо делаю не для себя. Но, по-моему, должно работать.

    В противном случае пиши мне, исправлю.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на C++:в матрице 4*5 замените на - 2 столбцы с положительными суммами элементов, а затем в качестве первого вставьте столбец из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100).
Ответы (1)
Злой хакер хочет испортить программное обеспечение на 40 компьютерах компании. На каждом компьютере 37 программ, каждая из которых состоит из 9000 строк кода.
Ответы (2)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
В произвольной целочисленной матрице поменять столбцы, содержащие минимальные и максимальные значения. Все элементы различны. Паскаль.
Ответы (1)
Заполнить двухмерный массив состоящий из 5x5 элементов, случайными числами в диапазоне от 0 до 100. Сформировать одномерный массив, состоящий из минимальных элементов строк исходного и """сортировать его по убыванию.
Ответы (1)