Задать вопрос
30 июня, 05:31

Написать на паскале программу.

Задано натуральное число n. Вычислить сумму ряда:

S=1-1/2+1/3-1/4+1/5 ... + - 1/n

+5
Ответы (1)
  1. 30 июня, 09:07
    0
    Var

    n, i: integer;

    s: real;

    begin

    s:=0;

    readln (n) ;

    for i:=1 to n do

    if i mod 2=0 then

    s:=s-1/i

    else

    s:=s+1/i;

    write (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать на паскале программу. Задано натуральное число n. Вычислить сумму ряда: S=1-1/2+1/3-1/4+1/5 ... + - 1/n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
Помогите написать программу в паскале! Написать программу в паскале: В одномерном массиве из 10 целых чисел вычислить сумму четных чисел ...
Ответы (1)
Помогите написать программу в паскале. Задано натуральное число n. Вычислить произведение цифр заданного числа.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)