Задать вопрос
29 апреля, 15:31

Помогите написать программу в паскале.

Задано натуральное число n. Вычислить произведение цифр заданного числа.

+2
Ответы (1)
  1. 29 апреля, 18:48
    0
    Var

    n, i, p: integer;

    begin

    p : = 1;

    read (n) ;

    while n > 0 do

    begin

    p : = p * (n mod 10) ;

    n : = n div 10;

    end;

    write (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в паскале. Задано натуральное число n. Вычислить произведение цифр заданного числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)
На паскале нужно решить задачи 1. Задано трехзначное число. Составьте программу, с помощью которой определите произведение кубов цифр этого числа. 2. Задано трехзначное число.
Ответы (1)
Дано натуральное число n. Определить, во сколько раз произведение всех цифр заданного числа больше его первой цифры. помогите написать программу в паскале.
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)