Задать вопрос
18 января, 21:17

Даны четыре целых числа. Определить, сколько из них нечетных. Нужно полное решение, не получается.

+4
Ответы (1)
  1. 19 января, 01:05
    0
    Чуть-чуть изменил, ты вводишь сначала число с клавиатуры, это N. В твоем случае - 4. Затем пишешь четыре целых числа. Он тебе выдаст количество нечетных.

    var a, n, i, k:integer;

    begin k:=0;

    read (n) ;

    while i
    read (a) ;

    if (a mod 2=1) then k:=k+1;

    i:=i+1;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны четыре целых числа. Определить, сколько из них нечетных. Нужно полное решение, не получается. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
1. Даны два целых числа A и B (A < B). Найти сумму всех чисел от A до B включительно. 2. Даны два целых числа A и B (A 0). Найти произведение всех чисел от A до B включительно. 3. Дан массив целых чисел Х. Найти сумму квадратов всех чисел. 4.
Ответы (1)
Даны два целых числа A и B (A
Ответы (1)
Паскаль абс можно попроще Нечётная прогрессия Известны количество и сумма нескольких подряд идущих нечётных чисел. Нужно найти эти числа. Input Со стандартного устройства ввода вводится 2 целых числа - N и S - количество и сумма.
Ответы (1)
Дано некоторое целое число. Написать программу, которая определяет, каких цифр в нем больше четных или нечетных. Кроме того, сформировать из данного числа два новых числа. Первое должно состоять из нечетных цифр исходного числа, а второе из четных.
Ответы (1)