Задать вопрос
31 января, 03:00

Паскаль абс можно попроще

Нечётная прогрессия

Известны количество и сумма нескольких подряд идущих нечётных чисел. Нужно найти эти числа.

Input

Со стандартного устройства ввода вводится 2 целых числа - N и S - количество и сумма.

Output

Нужно выдать на стандартное устройство вывода через пробел N искомых целых нечётных чисел. Пробел в конце строки не ставить.

Sample Input

5 35

Sample Output

3 5 7 9 11

+5
Ответы (1)
  1. 31 января, 06:37
    0
    Var N, S, a0, i: integer;

    begin;

    N:=0;

    S:=0;

    read (N) ;

    read (S) ;

    a0: = S div N - N + 1;

    write (a0) ;

    for i:=1 to N-1 do

    begin

    write (' ', a0 + 2*i) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль абс можно попроще Нечётная прогрессия Известны количество и сумма нескольких подряд идущих нечётных чисел. Нужно найти эти числа. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Максимум из 3-х чисел Даны 3 целых различных числа. Нужно определить, которое из них самое большое. Input Со стандартного устройства ввода вводится через пробел 3 целых числа, не превосходящих по модулю 10000.
Ответы (1)
1. Верное высказывание: а) Принтер - устройство ввода/вывода б) CD - ROM - устройство вывода в) Компакт-диск - устройство для хранения информации г) Клавиатура устройство ввода/вывода д) Монитор - устройство ввода
Ответы (1)
Возраст Маленькому марсианину Коляйно известны возраст папы и возраст мамы. Он хочет узнать, кто из них старше, но никак не может разобраться. Помогите ему в этом.
Ответы (1)
Дан массив из 15 целых чисел. Найти произведение элементов массива, кратных 3. Элементы массива, значения которых = 0, не считать кратные 3.
Ответы (1)
Напишите программу, которая считывает целые числа с консоли по одному числу в строке. Для каждого введённого числа проверить: если число меньше 10, то пропускаем это число; если число больше 100, то прекращаем считывать числа;
Ответы (1)