Задать вопрос
22 декабря, 01:16

Дан массив из 15 целых чисел.

Найти произведение элементов массива, кратных 3.

Элементы массива, значения которых = 0, не считать кратные 3.

Sample Input 1:

-5 4 6 3 - 1 7 0 7 8 - 4 - 6 - 9 7 - 2 1

Sample Output 1:

972

Sample Input 2:

-10 - 2 - 5 0 8 2 8 - 8 5 - 3 8 - 2 - 9 - 6 - 9

Sample Output 2:

1458

Sample Input 3:

5 5 7 5 8 - 10 8 4 - 5 - 1 - 5 9 - 5 - 8 0

Sample Output 3:

9

+3
Ответы (1)
  1. 22 декабря, 02:12
    0
    Var

    a:array[1 ... 15] of Integer;

    i, p:Integer;

    begin

    p:=1;

    for i:=1 to 15 do

    begin

    read (a[i]) ;

    if (a[i] mod 3 = 0) and (a[i] 0) then p:=p*a[i];

    end;

    Writeln (p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан массив из 15 целых чисел. Найти произведение элементов массива, кратных 3. Элементы массива, значения которых = 0, не считать кратные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая считывает целые числа с консоли по одному числу в строке. Для каждого введённого числа проверить: если число меньше 10, то пропускаем это число; если число больше 100, то прекращаем считывать числа;
Ответы (1)
Найти сумму чисел в текстовом документе. Почему пишет неизвестный идентификатор. var a, b:integer; begin assign (input,'input. txt') ; reset (input) ; assign (output,'output.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)