Задать вопрос
9 ноября, 09:50

Помогите решить задачу на массив в паскале:

Дана последовательность чисел а1, а2, ... аn. Требуется переставить числа в порядке возрастания.

+4
Ответы (1)
  1. 9 ноября, 12:25
    0
    Var i, n, j, m:integer;

    mass:array[1 ... 100] of integer;

    begin

    read (n) ;

    for i:=1 to n do

    read (mass[i]) ;

    for i:=n-1 downto 1 do

    for j:=1 to i do

    if mass[j]>mass[j+1] then

    begin

    m: = mass[j];

    mass[j]: = mass[j+1];

    mass[j+1]: = m;

    end;

    for i:=1 to n dowrite (mass[i]:5) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить задачу на массив в паскале: Дана последовательность чисел а1, а2, ... аn. Требуется переставить числа в порядке возрастания. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
Помогите написать программу в Паскале. Дан массив размера N. Массив отсортировать в порядке возрастания. Для отладки программы числа последовательностей сформировать с помощью генератора случайных чисел.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)