Задать вопрос
4 марта, 04:37

Помогите написать программу в Паскале.

Дан массив размера N.

Массив отсортировать в порядке возрастания.

Для отладки программы числа последовательностей сформировать с помощью генератора случайных чисел.

+1
Ответы (1)
  1. 4 марта, 07:48
    0
    Uses Crt;

    Const

    N = 13;

    Var

    A:array[1 ... N] of integer;

    i, j, Min, B:integer;

    Begin

    ClrScr;

    Randomize;

    Write ('Исходный массив:') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (2*N+1) - N;

    Write (' ', A[i])

    End;

    WriteLn;

    Write ('Отсортированный массив:') ;

    For i: = 1 to N do

    Begin

    Min:=i;

    For j: = i+1 to N do

    if A[j] < A[Min] then Min:=j;

    B:=A[i];

    A[i]:=A[Min];

    A[Min]:=B;

    Write (' ', A[i])

    End;

    ReadLn

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу в Паскале. Дан массив размера N. Массив отсортировать в порядке возрастания. Для отладки программы числа ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
Создать программу. Сформировать массив В (15). состоящий из чисел до 50. Найти сумму элементов этого массива. Массив сформировать при помощи генератора случайных чисел, элементы вывести на экран.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
Дан двумерный массив Х из вещественных элементов размерностью n 1. В одномерный массив переписать отрицательные элементы двумерного массива, расположенные ниже главной диагонали 2.
Ответы (1)