Задать вопрос
23 апреля, 22:42

Написать программу:

Даны длины сторон треугольника a, b, c. Является ли он прямоугольным?

+5
Ответы (1)
  1. 24 апреля, 01:04
    0
    Var a, b, c, t:real;

    begin

    readln (a, b, c) ;

    if b>a then begin

    t:=a;

    a:=b;

    b:=t;

    end;

    if c>a then begin

    t:=a;

    a:=c;

    c:=t;

    end;

    if (a*a=b*b+c*c) then writeln ('Треугольник прямоугольный') else writeln ('Треугольник не прямоугольный') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу: Даны длины сторон треугольника a, b, c. Является ли он прямоугольным? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу для определения является ли треугольник прямоугольным (для определения является ли треугольник прямоугольным, необходимо проверить выполняется ли теорема Пифагора)
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)
1. Даны два ненулевых числа а и b. Напишите программу для нахождения суммы, разности, произведения и частного. 2. Напишите программу для нахождение периметра и площади прямоугольного треугольника, если даны длины его катетов а и b. 3.
Ответы (1)
в паскале Запросить с клавиатуры 3 стороны треугольника и по ним определить, является ли он прямоугольным, сообщение вывести на экран. Подсказка. Для каждой стороны применить теорему Пифагора и проверить, выполняется ли она.
Ответы (1)