Задать вопрос
9 ноября, 17:56

Написать программу для определения является ли треугольник прямоугольным (для определения является ли треугольник прямоугольным, необходимо проверить выполняется ли теорема Пифагора)

+5
Ответы (1)
  1. 9 ноября, 19:15
    0
    Var a, b, c:real;

    begin

    readln (a, b, c) ;

    if c = sqrt (sqr (a) + sqr (b)) then writeln (' прямоугольный') else writeln (' не прямоугольный') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для определения является ли треугольник прямоугольным (для определения является ли треугольник прямоугольным, необходимо ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
в паскале Запросить с клавиатуры 3 стороны треугольника и по ним определить, является ли он прямоугольным, сообщение вывести на экран. Подсказка. Для каждой стороны применить теорему Пифагора и проверить, выполняется ли она.
Ответы (1)
Оператор цикла while ... do отличается от цикла for ... to, тем что 1. выполняется хотя бы один раз 2. выполняется хотя бы один раз 3. может не выполняться ни разу 4. выполняется известное число раз 5. выполняется неизвестное число раз
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
В цикле с предусловием тело цикла: А) Может не выполнятся ни разу Б) Выполняется в любом случае Г) Выполняется только тогда, когда результатом выполнения команды проверки условия является истина Д) Выполняется только тогда, когда результатом
Ответы (1)
3. Написать программу, которая запрашивает ввод целого числа в переменную B и выводит это число на экран. Проверить правильность работы программы на числах 1, - 5, 256, 10455. 4.
Ответы (1)