Задать вопрос
15 сентября, 05:10

Определим как "красивое" целое положительное трехзначное число Х, для которого выполняется следующее условие: сумма квадратов первой и последней цифр

равна квадрату средней цифры. Напишите программу, которая выводит на экран все "красивые" числа и их количество.

+4
Ответы (1)
  1. 15 сентября, 07:32
    0
    program zadacha_1;

    var a, b, c, a2, d:integer;

    begin d:=0;

    for a:=100 to 999 do begin

    a2:=a;

    b:=a2 mod 10;

    a2:=a2 div 10;

    c:=a2 mod 10;

    a2:=a2 div 10;

    if sqr (b) + sqr (a2) = sqr (c) then writeln (a) ;

    if sqr (b) + sqr (a2) = sqr (c) then d:=d+1;

    end;

    writeln ('количество = = >', d) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определим как "красивое" целое положительное трехзначное число Х, для которого выполняется следующее условие: сумма квадратов первой и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
Пользователь вводит положительное целое число, не превышающее 10^9, нужно написать программу, которая выводит на экран сумму цифр этого числа, меньших 7. если в числе нет цифр, меньших 7, требуется на экран вывести 0
Ответы (2)
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)