Задать вопрос
4 июля, 17:40

Напишите программу поиска всех трёхзначных чисел, сумма цифр которых и само число кратны 7 Paskal

+3
Ответы (1)
  1. 4 июля, 20:06
    0
    Var

    i, j, k: longint;

    begin

    for i : = 1 to 9 do

    for j : = 0 to 9 do

    for k : = 0 to 9 do

    if ((i + j + k) mod 7 = 0) and ((100*i+10*j+k) mod 7 = 0) then

    writeln (i, j, k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу поиска всех трёхзначных чисел, сумма цифр которых и само число кратны 7 Paskal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Запишите внутреннее представление десятичного числа - 104 в 8-разрядной ячейке памяти компьютера Ниже запишите ответ - только само число, без пояснений 2) Запишите внутреннее представление десятичного числа 79 в 8-разрядной ячейке памяти
Ответы (1)
Паскаль 1. Дано натуральное число. Верно ли, что в данном числе сумма цифр больше В, а само число делится на В (В вводится с клавиатуры). 2. Квадраты некоторых трехзначных чисел оканчиваются тремя цифрами, которые как раз и составляют исходные числа.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)
Помогите написать программу на Паскале. Напишите программу, которая в последовательности целых чисел вычисляет сумму всех чисел, которые кратны 6 или 11.
Ответы (1)
Логическое "ИЛИ" называется? 1. логическая связка для поиска всех других слов, кроме указанного в запросе 2. логическая связка для поиска по всем словам 3. логическая связка для поиска по любому из слов Ответ:
Ответы (1)