Задать вопрос
28 марта, 06:13

Определить, есть ли среди цифр заданного целого трехзначного числа одинаковые.

+2
Ответы (1)
  1. 28 марта, 08:02
    0
    Var

    a: word;

    b, c, d: byte;

    begin

    readln (a) ;

    b : = a mod 10;

    c : = a div 10 mod 10;

    d : = a div 100;

    writeln (b, ' ', c, ' ', d) ;

    if ((b in [c, d]) or (c in [b, d]) or (d in [b, c])) then

    writeln ('Yes, there are')

    else

    writeln ('No, there aren"t') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, есть ли среди цифр заданного целого трехзначного числа одинаковые. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Составьте алгоритм вычисления суммы квадратов цифр, заданного трехзначного числа. 2. Составить алгоритм вычисления разности кубов цифр, заданного восьмизначного числа. 3.
Ответы (1)
Запишите алгоритм, позволяющий определить, есть ли среди цифр заданного целого трёхзначного числа x одинаковые. Способ записи выберите самостоятельно.
Ответы (1)
Дано трёхзначное число. напишите программу которая определяет есть ли среди цифр заданного целого трёхзначного числа одинаковые
Ответы (1)
Напишите программу, которая: А) определяет, есть ли среди цифр заданного целого трехзначного числа одинаковые; Б) явл. ли число "перевертышем", т. е. Числом, десятичная запись которого читается одинаково слева направо и справа налево.
Ответы (1)
Определите (составьте алгоритм), есть ли среди цивр заданного целого трёхзначного числа одинаковые.
Ответы (1)