Задать вопрос
29 апреля, 20:33

Напишите рекурсивную функцию, которая

раскладывает число на простые сомножители.

Пример:

Введите натуральное число:

378

378 = 2*3*3*3*7

+2
Ответы (1)
  1. 29 апреля, 23:59
    0
    Var n : integer;

    function factorize (n : integer) : integer;

    var d : integer;

    begin

    d : = 2;

    while d * d < = n do begin

    if n mod d = 0 then begin

    write (d, '*') ;

    factorize (n div d) ;

    exit;

    end;

    d + = 1;

    end;

    if n > 1 then write (n) ;

    end;

    begin

    writeln ('Введите натуральное число:') ;

    readln (n) ;

    factorize (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите рекурсивную функцию, которая раскладывает число на простые сомножители. Пример: Введите натуральное число: 378 378 = 2*3*3*3*7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите рекурсивную и не рекурсивную функции вычисляющие НОД двух натуральных чисел с помощью модифицированного алгоритма евклида
Ответы (1)
Помогите написать программу Паскаль, очень прошу, вообще не шарю в программах, а так 2 поставят! Задача "A": Ввести натуральное число и найти сумму его цифр. Пример: Введите натуральное число: 12345. Сумма цифр 15.
Ответы (2)
1) Составить функцию, которая определяет наибольшее из трех чисел и привести пример ее использования. Пример: Введите три числа: 28 15 10 Наибольшее число: 28 2) Составить функцию, которая определяет сумму всех чисел от 1 до N и привести пример ее
Ответы (1)
Python. Уровень B. Ввести натуральное число и определить, верно ли, что в его записи есть две одинаковые цифры, стоящие рядом. Пример: Введите натуральное число: 12342 Нет. Пример: Введите натуральное число: 12245 Да.
Ответы (1)
Напишите рекурсивную функцию подсчёта количества цифр в натуральном числе. Формат входных данных На вход ваша программа получает одно натуральное число n (1≤n≤216-11≤n≤216-1). Формат выходных данных Выведите одно число - количество цифр в числе n.
Ответы (2)