Задать вопрос
8 марта, 14:59

Напишите рекурсивную и не рекурсивную функции вычисляющие НОД двух натуральных чисел с помощью модифицированного алгоритма евклида

+3
Ответы (1)
  1. 8 марта, 15:18
    0
    Рекурсивная:

    function NOD (x, y:integer) : integer;

    begin

    if x0 then NOD:=NOD (y mod x, x) else NOD:=y;

    end;

    var a, b:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    writeln ('НОД=', NOD (a, b)) ;

    end.

    Не рекурсивная:

    function NOD (x, y:integer) : integer;

    begin

    while (x0) and (y0) do

    if x>y then x:=x mod y else y:=y mod x;

    NOD:=x+y;

    end;

    var a, b:integer;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    writeln ('НОД=', NOD (a, b)) ;

    end.

    Пример:

    a=125

    b=50

    НОД=25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите рекурсивную и не рекурсивную функции вычисляющие НОД двух натуральных чисел с помощью модифицированного алгоритма евклида ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Составить программу для вычисления нод с помощью модифицированного алгоритма евклида
Ответы (1)
Python. Ввести с клавиатуры 2 натуральных числа и сравнить количество шагов цикла для вычисления их НОД с помощью обычного и модифицированного алгоритмов Евклида.
Ответы (1)
Ввести с клавиатуры два натуральных числа и найти их НОД с помощью алгоритма Евклида. Пример: Введите два числа: 21 14 НОД (21,14) = 7 язык Python
Ответы (1)
Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует
Ответы (1)