Задать вопрос
7 апреля, 10:29

Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до тех пор пока одно из них не станет равно нулю тогда второе и есть нод напишите программу которая реализует этот алгоритм какой цикл тут нужно использовать

+4
Ответы (1)
  1. 7 апреля, 12:26
    0
    Var

    a, b:integer;

    begin

    Write ('Введите два натуральных числа ') ; Readln (a, b) ;

    while ab do

    if a > b then a : = a - b

    else b : = b - a;

    Writeln ('НОД=', a)

    end.

    Тестовое решение:

    Введите два натуральных числа 28 16

    НОД=4
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Алгоритм евклида для вычисления нод двух натуральных чисел формируется так нужно заменять большее число на разность большего и меньшего до ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Модифицированный алгоритм Евклида для вычисления наибольшего общего делителя двух натуральных чисел, формулируется так: нужно заменять большее число на остаток от деления большего на меньшее до тех пор, пока остаток не станет равно нулю;
Ответы (1)
Составить программу вычисления суммы всех целых чисел от 0 до 100. 1 использовать цикл с предусловием. 2 использовать цикл с постусловием. 3 использовать цикл с параметром
Ответы (1)
Составьте программу нахождения суммы всех четных чисел от 10 до 100. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (1)
Составьте программу возведения в квадрат всех целых чисел от 0 до 50. 1) использовать цикл с предусловием. 2) использовать цикл с постусловием. 3) использовать цикл с параметром.
Ответы (2)
1) Напишите программу, которая вводит натуральное число N и нахо дит сумму всех натуральных чисел от 1 до N. Используйте сначала цикл с условием, а потом - цикл с переменной.
Ответы (1)