Задать вопрос
8 декабря, 10:25

Пусть даны координаты трёх точек на плоскости. Если они могут быть вершинами прямоугольного треугольника, вычислите его площадь

+2
Ответы (1)
  1. 8 декабря, 11:39
    0
    Program treyg;

    uses crt;

    var x1, y1, x2, y2, x3, y3 : integer;

    a, b, c, s, p : real;

    begin

    write ('Введите координаты первой точки: ') ;

    Readln (x1, y1) ;

    write ('Введите координаты второй точки: ') ;

    Readln (x2, y2) ;

    write ('Введите координаты третьей точки: ') ;

    Readln (x3, y3) ;

    a:=sqrt (sqr (x1-x2) + sqr (y1-y2)) ;

    b:=sqrt (sqr (x2-x3) + sqr (y2-y3)) ;

    c:=sqrt (sqr (x3-x1) + sqr (y3-y1)) ;

    if ((a+b) >c) and ((b+c) >a) and ((c+a) >b) then

    writeln ('Данные координаты не могут являться вершинами треугольника')

    else

    begin

    p: = (a+b+c) / 2;

    s:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    Writeln ('Площадь треугольника ', s) ;

    end

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Пусть даны координаты трёх точек на плоскости. Если они могут быть вершинами прямоугольного треугольника, вычислите его площадь ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите функциюS (x1, y1, x2, y2, x3, y3), которая принимает коорди- наты трёх точек на плоскости. Если они могут быть вершинами равно- бедренного прямоугольного треугольника, то функция дает площадь тре- угольника, в противном случае дает - 1.
Ответы (1)
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные данные Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Ответы (1)
Прямоугольник. Зная координаты трех вершин прямоугольника на координатной плоскости, определить координаты четвертой вершины. Входные данные В одной строке записаны шесть чисел - координаты трех вершин прямоугольника.
Ответы (1)
Вариант 2 1. Даны три числа. Найдите сумму второго и третьего числа. Найдите квадрат первого числа. 2. Даны длины сторон прямоугольника. Найдите площадь прямоугольника. 3. Даны длины катетов прямоугольного треугольника. Найдите периметр треугольника.
Ответы (1)
Ввести с клавиатуры координаты двух точек а и в на плоскости вещественный числа вычислить длину. программу нужно написать в паскале пример, как должно получиться введите координаты точки а 5.5 3.5 введите координаты точки b 1.5 2 длинна отрезка ab=4.
Ответы (1)