Задать вопрос
20 мая, 14:34

Составьте программу, которая формирует массив из 10 случайных чисел, принадлежащих промежутку [-9; 9], и выводит эти числа в столбец.

+5
Ответы (2)
  1. 20 мая, 15:35
    0
    Const

    n = 10;

    var

    x: array[1 ... n] of integer;

    i: integer;

    begin

    Randomize;

    Writeln ('Элементы массива:') ;

    for i : = 1 to n do

    begin

    x[i] : = Random (19) - 9;

    Writeln (x[i])

    end

    end.

    Тестовое решение:

    Элементы массива:

    -9

    0

    -3

    4

    3

    9

    -7

    9

    6

    -6
  2. 20 мая, 16:20
    0
    Program zz;

    var a:array[1 ... 10] of integer;

    i:integer;

    begin

    for i:=1 to 10 do

    a[i]:=random (19) - 9;

    for i:=1 to 10 do

    writeln (a[i]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая формирует массив из 10 случайных чисел, принадлежащих промежутку [-9; 9], и выводит эти числа в столбец. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая формирует массив из 12 случайных чисел принадлежащих промежутку - 5; 5, и выводит эти числа в столбец
Ответы (2)
составьте программу которая формирует массив из 12 случайных целых чисел принадлежащих промежутку [-5; 5] и выводит эти числа в столбец.
Ответы (1)
Составить программу, которая формирует массив из 8 случайных вещественных чисел, принадлежащих промежутку [8; 9) и выводит эти числа в столбец с двумя десятичных цифрами
Ответы (1)
Составить программу, которая формирует массив из 8 случайных вещественных чисел, принадлежащих промежутку [10; 11) и выводит эти числа в столбец с двумя десятичными цифрами
Ответы (1)
Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2; 3] и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!
Ответы (1)