Задать вопрос
22 мая, 05:21

Треугольник задан величинами своих углов и радиусом описанной окружности. Вычеслить длины сторон треугольника.

+5
Ответы (1)
  1. 22 мая, 08:53
    0
    Var

    a, b: array [1 ... 3] of real;

    r: real;

    begin

    writeln ('Введите углы (A, B, C), затем - радиус') ;

    readln (a[1], a[2], a[3], r) ;

    b[1] : = r * 2 * sin (a[1]) ;

    b[2] : = r * 2 * sin (a[2]) ;

    b[3] : = r * 2 * sin (a[3]) ;

    writeln ('a = ', b[1]) ;

    writeln ('b = ', b[2]) ;

    writeln ('c = ', b[3]) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Треугольник задан величинами своих углов и радиусом описанной окружности. Вычеслить длины сторон треугольника. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Вычеслить обьем куба, если длина ребра задана 2. Вычеслить площадь поверхности кирпича, если длины ребер заданы 3. Вычеслить длину окружности, если радиус задан.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
Треугольник задан длинами сторон А, В, С. Написать программу, определяющую, существует ли данный треугольник. Для решения этой задачи использовать сложные логические условия. Программа должна иметь дружественный интерфейс.
Ответы (1)
Напишите задачу в Паскале Треугольник задан длинами сторон. Если такой треугольник существует, то сообщить какой он: Равносторонний, равнобедренный или разносторонний
Ответы (1)