Задать вопрос
1 мая, 10:49

Дана последовательность из N (2<=N<=100000) различных чисел.

Выписать в возрастающем порядке все целые числа находящиеся в интервале от минимального до максимального значения элементов этой последовательности, которые не находятся в данной последовательности.

+1
Ответы (1)
  1. 1 мая, 11:47
    0
    Var

    i, i_beg, i_end, k:longint;

    p:set of longint;

    begin

    Writeln ('Вводите целые числа большие двух, конец ввода по числу 0') ;

    i_beg:=1000000; i_end:=0;

    repeat

    Read (k) ;

    if k0 then

    begin

    if i_beg>k then i_beg:=k

    else if i_end
    Include (p, k)

    end

    until k=0;

    Writeln ('Числа, не входящие в последовательность:') ;

    for i:=i_beg to i_end do

    if not (i in p) then Write (i,' ')

    end.

    Тестовое решение:

    Вводите целые числа большие двух, конец ввода по числу 0

    6 12 9 14 10 19 17 11 7 0

    Числа, не входящие в последовательность:

    8 13 15 16 18
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность из N (2 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Дана последовательность чисел. найти дана последовательность чисел. найти минимальное и максимальное число и вычислить их среднее арифметическое. в паскале
Ответы (1)
Это в Паскале. Первая задача: Дана последовательность чисел, оканчивающихся отрицательным числом. Найти среднее арифметическое введенных положительных чисел. И вторая: Дана последовательность чисел, количество которых заранее не известно.
Ответы (1)
укажите истинное высказывание (отметьте точкой) алгоритм всегда представляет собой некоторую последовательность вычислений алгоритм может представлять собой некоторую последовательность вычислений, а может последовательность действий
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)