Задать вопрос
1 октября, 13:47

В массиве из 10 целых чисел подсчитать количество элементов меньших, чем среднее арифметическое минимального и максимального элементов.

+5
Ответы (1)
  1. 1 октября, 14:47
    0
    Var a: array[1 ... 10] of integer;

    begin k:=0;

    for i:=1 to 10 do begin

    writeln ('Введите 10 чисел') ; readln (a) ;

    max:=a[i]; min:=a[i]

    for i:=2 to 10 do begin

    if a[i]>max then max:=a[i];

    if a[i]
    s: = (min+max) / 2;

    for i:=1 to 10 do begin

    if a[i]
    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «В массиве из 10 целых чисел подсчитать количество элементов меньших, чем среднее арифметическое минимального и максимального элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Паскаль. Вычислить разность максимального среди элементов, имеющих четные значения, и максимального среди элементов, имеющих нечетные значения, в заданном целочисленном массиве из 30 положительных элементов (в предположении, что в массиве есть и
Ответы (1)
Напишите программу вычисления разности максимального среди элементов, имеющих чётные значения, и максимального среди элементов, имеющих нечётные значения, в заданном целочисленном массиве из 10 положительных элементов (в предположении, что в массиве
Ответы (1)
Сформируйте массив случайных целых чисел от 10 до 30. Количество элементов в массиве 12. Найдите сумму минимального и максимального элементов.
Ответы (1)
Помогите составить программу в Paskal! 1) Вычислите значение минимального элемента массива 2) Вычислите сумму минисального и максимального элементов 3) Выведите номер минимального элемента 4) Выведите номера максимальных элементов и их количество
Ответы (1)