Задать вопрос
30 июля, 12:15

Составить программу начисления стипендии группе студентов из 25 человек

по итогам сессии из 5 экзаменов. Стипендия в размере 900 рублей

начисляется студенту, не имеющему троек. Посчитать сумму, необходимую

для выплаты стипендии и вывести список студентов, получающий стипендию.

+3
Ответы (1)
  1. 30 июля, 14:19
    0
    Program Stipendiya;

    type

    Student = record

    Ocenka: array [1 ... 5] of Byte;

    end;

    var

    i, j: Byte;

    Summa: Integer;

    Troechik: Boolean;

    Studenti: array [1 ... 25] of Student;

    begin

    for i:=1 to 25 do

    begin

    / / Zapolnyaem ocenki studentov:

    WriteLn ('Vvedite ocenki '+IntToStr (i) + ' studenta: ') ;

    for j:=1 to 5 do

    begin

    Write ('Ocenka za '+IntToStr (i) + ' ekzamen: ') ;

    ReadLn (Studenti[i]. Ocenka[j]) ;

    end;

    end;

    / / Chitaem summu

    S:=0;

    WriteLn ('') ;

    for i:=1 to 25 do

    begin

    //

    Troechik:=False;

    //

    for j:=1 to 5 do

    if Studenti[i]. Ocenka[j] < 4 then Troechik:=True;

    //

    if not Troechik then

    begin

    WriteLn ('Vidat stipendiu '+IntToStr (i) + ' studentu') ;

    Summa:=Summa + 900;

    end;

    end;

    / / Vivod summi vsex stipendii

    WriteLn ('Summa vsex stipendii = '+IntToStr (Summa)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу начисления стипендии группе студентов из 25 человек по итогам сессии из 5 экзаменов. Стипендия в размере 900 рублей ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
решите задание 3 Задание 2. Создайте файл информации по итогам сессии result. dat. Для каждой группы каждого курса в файл заносится информация (количество курсов и групп на курсе фиксировано, сами номера курсов и групп в записи не хранятся) :
Ответы (1)
Список a содержит натуральные числа. Создать список b, который содержит только простые числа из a в порядке возрастания. Список b сортировать методом простого выбора. Вывести на печать список b или сообщить, что он пуст.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)