Задать вопрос
9 апреля, 15:44

Дана

последовательность слов. Напечатать

те слова последовательности, которые

отличны от последнего слова и удовлетворяют

следующему свойству: слово симметрично

+5
Ответы (1)
  1. 9 апреля, 19:28
    0
    uses

    System. Collections. Generic;

    function reverse (const s: String) : String;

    begin

    if Length (s) = 1 then reverse : = s else

    reverse : = s[Length (s) ] + reverse (Copy (s, 1, Length (s) - 1)) ;

    end;

    var

    lst: List : = new List () ;

    s, s1: string;

    begin

    writeln ('Конец последовательности - пустая строка') ;

    while (true) do

    begin

    readln (s) ;

    if (s. Length = 0) then

    break

    else

    lst. Add (s) ;

    end;

    writeln () ;

    foreach s in lst do

    begin

    if ((s lst. Last ()) and (s = reverse (s))) then

    writeln (s) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность слов. Напечатать те слова последовательности, которые отличны от последнего слова и удовлетворяют следующему ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Дана непустая последовательность целых чисел, оканчивающаяся нулем (0 является признаком окончания последовательности и в последовательность не входит). Найти и напечатать: 1. Сумму всех чисел, больших Х (значение Х вводится с клавиатуры).
Ответы (1)
Дана непустая последовательность слов из строчных латинских букв; между соседними словами - запятая, за последним словом - точка. Напечатать все буквы, которые входят в наибольшее количество слов этой последовательности. Писать на Pascal.
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)