Задать вопрос
24 апреля, 20:49

Дано натуральное число:

- найти сумму цифр этого числа;

- верно ли, что число начинается и заканчивается одной и той же цифрой.

+5
Ответы (1)
  1. 24 апреля, 21:35
    0
    Program asdf;

    var a, i. b:integer;

    s:string;

    begin

    readln (a) ;

    s:=inttostr (a) ;

    a:=length (s) ;

    b:=0;

    for i:=1 to a do

    b:=b+s[i];

    writeln (b) ;

    if s[1]=s[a] then writeln ('равны') else writeln ('неравны') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано натуральное число: - найти сумму цифр этого числа; - верно ли, что число начинается и заканчивается одной и той же цифрой. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Помогите решить! 1) Дано натуральное трехзначное число N. Определить сумму и произведение его цифр. 2) Дано натуральное трехзначное число N. Найдите число, образованное перестановкой цифр исходного числа в обратном порядке.
Ответы (1)
Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой.
Ответы (1)
Составить программу, прошу) Дано натуральное число, верно ли что оно начинается и заканчивается одной и той же цифрой.
Ответы (1)
1. Дано натуральное число. Верно ли, что сумма его цифр есть четное число, а само число не превышает b? 2. Дано натуральное число. Верно ли, что сумма его цифр больше m а само число делится на n?
Ответы (1)