Задать вопрос
27 июня, 20:39

С1. Составить алгоритм и написать программу на вычисление

скорости или пути, при условии, если t<3 часов, тогда вычисляем скорость иначе путь.

Каждую строку программы прокомментировать. Входные данные t = 80 мин.

+4
Ответы (1)
  1. 27 июня, 22:59
    0
    Алгоритм:

    Начало

    Ввод t

    Если t>1 часа, то

    начать выполнение операторов

    ввод S;

    V=S/t;

    вывод V

    закончить выполнение операторов

    иначе

    начать выполнение операторов

    ввод V;

    S=Vt;

    вывод S;

    закончить выполнение операторов

    Var S, V, t:integer;

    begin

    read (t) ;

    if t>1 then

    begin

    read (s) ;

    v:=s/t;

    writeln ('Скорость=', v) ;

    end

    else

    begin

    read (v) ;

    s:=v*t;

    writeln ('Расстояние=', s) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С 1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t>1 часа, тогда вычисляем скорость, иначе путь. Каждую строку программы, прокомментировать. Входные данные t=2 часа
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1. Составить алгоритм и программу нахождения суммы следующих чисел: 1, 12, 35, 70, 117, ... 532. 2.-х- 3.
Ответы (1)
Соберите алгоритм содержащий план работы программиста над созданием программы (я здесь напишу в разброс и вы по порядку 1 ... 2 ... И Тд) Создать программу. получить задание. Отправить программу пользователю. Написать алгоритм. Отладить программу
Ответы (1)
Если данное предложение представить в виде алгоритма то это будет: Если сделаешь уроки, то можешь пойти в кино, иначе сиди дома. А) Линейный алгоритм В) Алгоритм с ветвлением С) Комбинированный алгоритм D) Алгоритм с циклом
Ответы (1)