Задать вопрос
18 января, 08:23

С 1. Составить алгоритм и написать программу на вычисление

скорости или пути, при условии, если t>1 часа, тогда

вычисляем скорость, иначе путь. Каждую строку программы, прокомментировать.

Входные данные t=2 часа

+1
Ответы (1)
  1. 18 января, 09:20
    0
    Алгоритм:

    Начало

    Ввод t

    Если t>1 часа, то

    начать выполнение операторов

    ввод S;

    V=S/t;

    вывод V

    закончить выполнение операторов

    иначе

    начать выполнение операторов

    ввод V;

    S=Vt;

    вывод S;

    закончить выполнение операторов

    Var S, V, t:integer;

    begin

    read (t) ;

    if t>1 then

    begin

    read (s) ;

    v:=s/t;

    writeln ('Скорость=', v) ;

    end

    else

    begin

    read (v) ;

    s:=v*t;

    writeln ('Расстояние=', s) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С 1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t>1 часа, тогда вычисляем скорость, иначе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С1. Составить алгоритм и написать программу на вычисление скорости или пути, при условии, если t
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)