Задать вопрос
24 июля, 06:48

Дается последовательность из N чисел. Выведите разницу между максимальным минимальным элементами последовательности ответ

+3
Ответы (1)
  1. 24 июля, 07:14
    0
    Const n=4; { любое число N от 1 до 100000}

    var a:array [1 ... n] of integer;

    b, min, max, s:integer;

    proizvedenie:real;

    beginwriteln ('Введите n чисел') ;

    for b:=1 to n do read (a[b]) ;

    for b:=1 to n do

    write (a[b],' ') ;

    min:=a[1];

    max:=0;

    for b:=1 to n do

    begin

    if a[b]>max then max:=a[b];

    if a[b]
    end;

    proizvedenie:=max-min;

    writeln;

    writeln ('minimum ', min,' ','maximum ', max,' Proizvedenie = ', proizvedenie) ; readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дается последовательность из N чисел. Выведите разницу между максимальным минимальным элементами последовательности ответ ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Файл Date. in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным, минимальным и какие не является ни минимальным, ни максимальным.
Ответы (1)
1) Дана последовательность из N элементов (N вводится с клавиатуры). Является ли эта последовательность возрастающей? 2) Найти разницу между максимальным и минимальным числом последовательности.
Ответы (1)
3. Дана последовательность из N различных чисел. Найти сумму её членов, распо-ложенных между максимальным и минимальным элементами (в сумму включить и оба эти числа).
Ответы (1)