Задать вопрос
28 февраля, 20:10

1) Дана последовательность из N элементов (N вводится с клавиатуры). Является ли эта последовательность возрастающей?

2) Найти разницу между максимальным и минимальным числом последовательности.

+3
Ответы (1)
  1. 28 февраля, 22:04
    0
    Var

    i, max, min, flag, a, b, n:integer;

    begin

    read (n) ;

    flag:=0;

    for i:=1 to n do

    begin

    read (a) ;

    if i=1 then

    begin

    max:=a;

    min:=a;

    end

    else

    begin

    if a>max then

    max:=a;

    if min>a then

    min:=a;

    if b>a then

    flag:=1;

    b:=a;

    end;

    end;

    if flag=0 then

    writeln ('Yes')

    else

    writeln ('No') ;

    writeln (max-min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Дана последовательность из N элементов (N вводится с клавиатуры). Является ли эта последовательность возрастающей? 2) Найти разницу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Файл Date. in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным, минимальным и какие не является ни минимальным, ни максимальным.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)