Задать вопрос
16 сентября, 23:45

3. Дана последовательность из N различных чисел. Найти сумму её членов, распо-ложенных между максимальным и минимальным элементами (в сумму включить и оба эти числа).

+1
Ответы (1)
  1. 17 сентября, 00:43
    0
    Программа на паскале:

    const n=10;

    var a:array[1 ... n] of integer;

    max, min, imax, imin, s, i:integer;

    begin

    Randomize;

    for i:=1 to n do begin

    a[i]:=random (51) ;

    write (a[i],' ') ;

    end;

    writeln;

    max:=a[1]; imax:=1;

    min:=a[1]; imin:=1;

    for i:=1 to n do

    begin

    if a[i]>max then begin max:=a[i]; imax:=i; end;

    if a[i]
    end;

    writeln ('max = ', max,' min = ', min) ;

    s:=0;

    if imax
    then for i:=imax to imin do s:=s+a[i]

    else for i:=imin to imax do s:=s+a[i];

    writeln ('s = ', s) ;

    end.

    Пример:

    38 15 4 5 9 15 24 40 12 9

    max = 40 min = 4

    s = 97
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «3. Дана последовательность из N различных чисел. Найти сумму её членов, распо-ложенных между максимальным и минимальным элементами (в сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
Файл Date. in файл содержит 3 различных целых чисел, разделенных пробелами. Написать программу, которая укажет, какие из чисел является максимальным, минимальным и какие не является ни минимальным, ни максимальным.
Ответы (1)
Дан двумерный массив размером n*m, заполненный случайными числами. Найти сумму его элементов, расположенных между максимальным и минимальным элементами (включая оба этих числа) - программный код для делфи
Ответы (1)
1) Дана последовательность из N элементов (N вводится с клавиатуры). Является ли эта последовательность возрастающей? 2) Найти разницу между максимальным и минимальным числом последовательности.
Ответы (1)
Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности. Формат входных данных Первая строка входного файла содержит целое число N (1 < = N < = 100000).
Ответы (1)